[tpm] MetaCpan VM

Olaf Alders olaf.alders at gmail.com
Wed Oct 30 08:12:09 PDT 2013

On 2013-10-30, at 11:01 AM, Tom Legrady wrote:

> I tried following the instructions in Olaf's talk.


> The first complication I came across is in the slides that git-s the various repositories. It DOESN'T git metacpan-developer, yet the next step is to cd into that directory. As well, the slide contains "cd ../metacpan-developer". It is really an uncle directory, one level up? or is it a sibling, contained within .../metacpan/? I have it as a sibling.

The README is here:


metacpan and metacpan-developer are sibling folders, so it sounds like you have it set up correctly.

├── metacpan
│   ├── cpan-api
│   ├── metacpan-explorer
│   ├── metacpan-puppet
│   └── metacpan-web
└── metacpan-developer

> When I run "vagrant up and vagrant ssh" I get an error message about an unsupported version of VirtualBox, telling me to run 4.0 or 4.1. Bu when I run virtualbox and click on Help->Contents, the title page of the maual shows "Version 4_1_18 Debian".
> Virtualbox tells me I'm missing virtualbox-ose, so I'm adding that.

I'm no VirtualBox expert, but let us know how you make out with that.  This also reminds me that I need to post my slides. :)

Olaf Alders
olaf.alders at gmail.com


866 503 2204 (Toll free - North America)
416 944 8306 (direct)

More information about the toronto-pm mailing list