[sf-perl] Does anybody on this list host with Hurricane Electric?

Dave Turner dave at wrightpopcorn.com
Mon Apr 28 19:00:34 PDT 2008

The reason that I'm asking is that I'm pulling my hair out trying to
install Crypt::OpenPGP, through the CPAN shell, in my local space and
I'm getting the error that I don't have write permission to the source
directory. I've set my path to my local directory physically so I know
that's been done. I've asked over on PerlMonks and tried to the best of
my ability, since I work under windows, what was suggested to no avail.

This was the advice given:

Older versions of ExtUtils::AutoInstall
had the following snippet of code

sub _can_write {
    my $path = shift;
    mkdir ($path, 0755) unless -e $path;

    require Config;
    return 1 if -w $path and -w $Config::Config{sitelib};

    print << ".";
*** You are not allowed to write to the directory '$path';
    the installation may fail due to insufficient permissions.
    # ...

while newer versions just test for -w $path, i.e.

sub _can_write {
    my $path = shift;
    mkdir ($path, 0755) unless -e $path;

    return 1 if -w $path;

    # ...
In other words, if $path isn't the problem, it could still be
$Config::Config{sitelib}  (...something the error message doesn't say).

Now I'm not entirely sure, but I suspect Config.pm might not be taking
into account that you've told your CPAN shell to install to some other
local directory...

Anyhow, I would just try installing the current version of
into some local directory (and set PERL5LIB appropriately, or some
such), and see if that works then. (If it doesn't - for some other
reason - you could also copy the original (5.8.0)
ExtUtils/AutoInstall.pm to some local directory, and edit the respective
line to no longer test for Config{sitelib}.)

I tried to re-install ExtUtils::AutoInstall in to my local directory but
I'm getting stung when it's grabbing the associated modules saying that
I don't have write permission in the sources directory.

Hurricane has been less than helpful in trying to get this resolved.
I've got an open ticket that hasn't been responded to in at least two
weeks so that's why I'm turning here.

Sorry if this is long but I've been fighting this for a while and
getting nowhere.

Anybody here use them as a host and had problems installing modules
locally? If so, how did you solve it?\


More information about the SanFrancisco-pm mailing list