[Pdx-pm] Win32::TieRegistry oddity

Roderick A. Anderson raanders at acm.org
Tue Feb 20 05:23:28 PST 2007

I've run into what appears to be a new problem.  Suddenly scripts that 
have been working for 2-3 years on two different systems are having 
problems with Win32::TieRegistry->SubKeyNames.

While running the script through the debugger I found I could

	x $TieRegistry->SubKeyNames

just before the script call and get the error but when I next step the 
script the real call would work.

Not sure how long this has been going on.  The other system that runs 
this script appears to be working fine though when I ran the script 
through the debugger it failed the same.

I tried wrapping a worthless call in an eval block but not sure if a 
later problem I discovered when I ran the script to the end is masking 
the success of the eval block trick.
    So until I can sort this other issue out and get back to the 
Win32::TieRegistry stuff I was hoping someone on the list might have 
some suggestions on how to get past the failing SubKeyNames call.


More information about the Pdx-pm-list mailing list