[Pdx-pm] runs in term; fails in cron

Eric Wilhelm scratchcomputing at gmail.com
Mon Sep 12 23:00:41 PDT 2005

# from John Springer
# on Monday 12 September 2005 02:53 pm:

> From terminal everything works fine, but when I run from cron I get  
>no element found at line 1, column 0, byte -1 at /usr/www/users/
>orygun/PerlLib/XML/Parser.pm line 187

Does that look like this?

    $result = $expat->parse($arg);

Looks like XML::Parser::Expat is doing some fancy stuff with @INC, but I 
don't think that's you're problem:

  google  XML::Parser "no element found at line 1, column 0"

It actually sounds like a missing file, broken pipe, or something of 
that sort.

>I've had the script print the contents of @INC, and it's identical  
>under both cron and from terminal.
>I've tried changing my script to use lib and removing the PER5LIB var
>   and some other stuff, but can't seem to make any headway.

It seems more likely that it's some other environment variable or other 
difference.  Is $HOME set in your crontab?

"Everything goes wrong all at once."
--Quantized Revision of Murphy's Law

More information about the Pdx-pm-list mailing list