[Pdx-pm] runs in term; fails in cron

John Springer techdude at dpo.org
Mon Sep 12 14:53:55 PDT 2005

I'm trying to run a script that runs fine in terminal but fails when  
I run from cron.

The script uses XML::RSS::Parser.
I've set PERL5LIB env variable to my lib directory in both cron  
and .bashrc (needed to do this to get CPAN to install in my private  
lib, plus seems to eliminate the need to do "use lib..." ).

 From terminal everything works fine, but when I run from cron I get  
no element found at line 1, column 0, byte -1 at /usr/www/users/ 
orygun/PerlLib/XML/Parser.pm line 187

I've had the script print the contents of @INC, and it's identical  
under both cron and from terminal.
I've tried changing my script to use lib and removing the PER5LIB var  
and some other stuff, but can't seem to make any headway.

Any ideas?

   John Springer
   Tech Dude
   Democratic Party of Oregon
   (503)224-8200 x235

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.pm.org/pipermail/pdx-pm-list/attachments/20050913/d2620dfe/attachment.html

More information about the Pdx-pm-list mailing list