[Melbourne-pm] Looking for a Perl consult... problem with sessions

Ben Hare benhare at gmail.com
Sun Dec 2 19:26:02 PST 2012

the error you gave doesn't seem to indicate apache-session is missing
necessarily. perhaps you need to restart apache after fixing the
permissions? ( if it's mod-perl you will ).

On 3 December 2012 13:53, Rick Giner <rickginer at gmail.com> wrote:
> I came to the same conclusion, but Apache::Session doesn't appear in the
> codebase. Is it possible that other files could be being used outside the
> web root?
> What do you think might require permissions? I have added the /sessions/
> folder and given it ownership of www-data (same as Apache) and even tried
> permissions 777. Are there other folders I should be lookign at? Or
> particular users I should try executing processes as?
> To my knowledge the OS hasn't been changed recently, but I don't think it
> was a well-maintained box. When I restarted it last week Apache complained
> about missing files from sites that had been decommissioned, but their
> definitions not removed from sites-enabled - so someone had been tinkering
> in there and not properly tidying up after themselves. No idea when the box
> was last restarted, but it's quite possible modules were uninstalled or
> changed months ago and no one would have noticed until the box was restarted
> last week
> On 3/12/12 2:06 PM, Benjamin wrote:
> Appears to be using Apache::Session somewhere in there and sounds a lot like
> permission issues.
> Have you recently moved the site to a new environment or upgraded the host
> OS?
> Can you grep the Perl source for the application for "Apache::Session" and
> grab the chunk of related code?
> Ben
> On Mon, Dec 3, 2012 at 1:59 PM, Rick Giner <rickginer at gmail.com> wrote:
>> I wonder if anyone can help. This may only take a short time to debug for
>> someone in the know. More than happy to compensate for any time spent on
>> it...
>> It's been a long while since I have worked with Perl, I am in a Ruby role
>> right now but we have an old (12 year old) Perl website that stopped working
>> after the server rebooted. The shopping cart did, anyway.
>> It seems to be trying to read session information relating to the shopping
>> cart, the error showing up in the log is a "Could not open file
>> '/var/lock/session/Apache-Session-blah.lock' for writing: No such file or
>> directory at /usr/share/perl/5.8/CGI/Carp.pm line 314". The /session/ folder
>> it refers to doesn't actually exist, though even after I created it the
>> error persists and no session files are being written.
>> If anyone has any time to help, we would greatly appreciate it and can
>> arrange for a console into the server and much beer + cash prizes for anyone
>> that helps solve our problem!
>> Many thanks,
>> Rick Giner
>> 0416 500 924
>> _______________________________________________
>> Melbourne-pm mailing list
>> Melbourne-pm at pm.org
>> http://mail.pm.org/mailman/listinfo/melbourne-pm
> _______________________________________________
> Melbourne-pm mailing list
> Melbourne-pm at pm.org
> http://mail.pm.org/mailman/listinfo/melbourne-pm

Benjamin J. Hare
Professional Web Development Services
ABN: 22-48-55-71-887
Phone: +61-415-607-197
Web: http://www.benhare.com
Email: ben at benhare.com

More information about the Melbourne-pm mailing list