[Melbourne-pm] CPAN Install

Toby Corkindale toby.corkindale at strategicdata.com.au
Thu Oct 29 22:01:00 PDT 2009

Gerd Berner wrote:
> Hello all
> It seems I have broken my CPAN shell and I'm struggling to find a way to 
> fix it, so any help would be appreciated!
> This machine is windows 2003 running ActivePerl-  This was 
> installed using the MSI installer, which comes with a built in 'Repair' 
> function.  I assume that this function would perform a checksum 
> comparison and fix any broken files? Ran it with crossed fingers - did 
> not fix the problem.  I tested a couple of different module installs and 
> they all fail with a similar message.
> when I try to 'reload index'  I also get the same error but also 
> warnings that my 02packages.details.txt.gz does not contain a Line-Count 
> header or a Last-Updated header (which cant be a good thing!).  When I 
> looked at this archive it was unreadable, so I replaced both it and 
> 03modlist.data.gz with fresh copies from CPAN, but still the same error 
> results when I try to install Net::SCP.
> Short of re-installing Perl, I'm not sure what else to do or why the 
> CPAN shell became unstable in the first place.  I have tended to use 
> both PPM and CPAN on the same Perl install, but I wouldnt have thought 
> that would be the cause.

This is a rather blunt approach to fixing it, but..
Go into C:\Perl\cpan\
and delete the entire "build" and "authors" directories.

Erm, wait, I think I'm thinking of CPANPLUS.. but give it a try with 
cpan too; I reckon I've seen a bug crop up with a partially-downloaded 
file causing one of cpan's subsiduary modules to crap out.

Or failing that.. have you tried using CPANPLUS?
(run cpanp from the command line)


More information about the Melbourne-pm mailing list