[DFW.pm] Trouble running a simple perl program

Tommy Butler dfwpm at internetalias.net
Fri Jan 10 12:25:40 PST 2014

I'm curious: Is there a particular reason why you are using ActiveState
Perl instead of Strawberry?

In addition to this list I aways recommend that questions be asked on
www.perlmonks.org as well.  The site looks like it's straight out of the
nineties, but it is actually tremendously useful.  They have a few
resident Perl-On-Windows gurus too.

--Tommy Butler

On 01/10/2014 02:05 PM, rickazevedo2 at lycos.com wrote:
> Sorry, but I have no idea.  Is the Perl executable in XP compatibility
> mode?
> on Jan 10, 2014, *John Fields* <wigthft at gmail.com> wrote:
>     Well poo.  Getting the version worked on Wednesday night.
>     No,  because you are telling what you have (win8) to treat the
>     program as if it was running on XP.  Or to actually be backward
>     compatible for this one program. Because win8 doesn't look back.
>     Like a shark it has no neck.
>     (Futurama joke)
>     Try right clicking on the Perl.exe executable, select properties,
>     compatibility tab,  XP Service Pack 3 mode.  Hmmmmmm.
>     On Jan 10, 2014 1:00 PM, <rickazevedo2 at lycos.com
>     <mailto:rickazevedo2 at lycos.com>> wrote:
>         perl -v gave me the same error message.  Wouldn't XP
>         Compatibility mode be wrong for Windows 8?
>         on Jan 10, 2014, *John Fields* <wigthft at gmail.com
>         <mailto:wigthft at gmail.com>> wrote:
>             Hmmm.  Just like Padre was doing at first.
>             Let's recheck: run "Perl -v" and see if it still gives you
>             the version number and the paragraph of text.
>             That should still work.  If it doesn't then something is
>             different since wed night.  May need to apply the XP
>             Compatibility mode setting to the Perl.exe file under
>             c:\strawberry since win8 makes life hard just because it
>             seems.
>             On Jan 10, 2014 11:10 AM, <rickazevedo2 at lycos.com
>             <mailto:rickazevedo2 at lycos.com>> wrote:
>                 With the command line open, I type "perl helloworld.pl
>                 <http://helloworld.pl>" (the name of the file) and hit
>                 enter.  It gives me the "0xc000007" error message,
>                 refusing to execute the program.  I looked up answers
>                 online and a lot of them are "reboot the machine" "try
>                 reinstalling" etc.  I rebooted and it didn't fix
>                 anything.  A registry-fixer was recommended but I
>                 decided to uninstall it after installing.  It would be
>                 nice to have some help.  Thank you.  Rick Azevedo

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.pm.org/pipermail/dfw-pm/attachments/20140110/fceb9bc4/attachment.html>

More information about the Dfw-pm mailing list