[Chicago-talk] LWP Error

richard at rushlogistics.com richard at rushlogistics.com
Wed Dec 30 09:32:50 PST 2015

Actually, it appears to be an LWP issue. Not sure if it's a bug or a 
feature but I tried it this way and it worked:
my $req = HTTP::Request->new( 'POST', $url );
$req->content( $json_string );
my $response = $ua->request( $req );
However, this does not:

my $response = 
Content => $json_string);

On Wed, 30 Dec 2015 10:51:52 -0600, Steven Lembark  wrote:

       On Mon, 28 Dec 2015 14:13:07 -0600
richard at rushlogistics.com wrote:

Request Error

The server encountered an error processing the request. See server logs 
for more details. 


404 == Not Found == they cannot map your path onto anything they handle. 

Odd that you got the server error, which is normally in the 500's. 

I love their remedy: Go check the logs. 

I'd call/email the support line at whomever you are dealing with and
ask them: if you have verified that the host exists (e.g., with
a browser or telnet to port 80 on the server) and are following their
rules for the path then it's on them to tell you what is wrong with
the request. 

Steven Lembark 3646 Flora Pl
Workhorse Computing St Louis, MO 63110
lembark at wrkhors.com +1 888 359 3508
Chicago-talk mailing list
Chicago-talk at pm.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.pm.org/pipermail/chicago-talk/attachments/20151230/142064f0/attachment.html>

More information about the Chicago-talk mailing list