[Chicago-talk] cpan problems in Fedora 9

Alan Mead amead2 at alanmead.org
Thu Sep 11 05:42:16 PDT 2008

I know this isn't a Fedora mailing list but if any of use F9, I think 
you may have solved this problem and some of you may know what level of 
support Perl has in Fedora these days.

I've previously used FC3 & FC4, and in F9 the cpan script is apparently 
split off as a separate rpm (which is inconvenient).  When I tried to 
use yum to install the perl-CPAN module, I get an error message "Error: 
Missing Dependency: perl = 4:5.10.0-20.fc9 is needed by package 
perl-CPAN-1.9205-20.fc9.i386 (fedora)" which is funny (ha ha) because 
the installed version of Perl is 5.10.0-31.fc9...  I don't know whether 
I'll have problems later? but I think I have solved it by manually 
downloading perl-CPAN and forcing it to be installed.

I was also wondered whether anyone had a thought about whether it's 
better to use Fedora's pre-compiled modules or just use cpan?  I guess 
the pre-built DBI/DBD modules have been useful, but a lot of the modules 
I might use are not there so I've always just relied upon the cpan 
script in the past.


Alan D. Mead, Ph.D. 
Assistant Professor, Institute of Psychology
Scientific Adviser, Center for Research and Service
Illinois Institute of Technology
3101 South Dearborn, 2nd floor
Chicago IL 60616

Skype: alandmead
+312.567.5933 (Campus)
+815.588.3846 (Home Office)
+312.567.3493 (Fax)


Be not afraid of life. 
Believe that life is worth living, 
and your belief will help create the fact.
  -- Henry James

More information about the Chicago-talk mailing list