FW: APM: RE: Pg.pm

Tom Bakken tom.bakken at tx.usda.gov
Tue Sep 16 07:54:42 CDT 2003

Tom Bakken
Information Resource Manager
USDA, Rural Development
101 South Main, Suite 102
Temple, TX 76501

Phone: 254-742-9726 Fax: 254-742-9709 
Email: tom.bakken at tx.usda.gov

-----Original Message-----
From: Philip Molter [mailto:hrunting at texas.net] 
Sent: Monday, September 15, 2003 5:42 PM
To: Tom Bakken
Subject: RE: APM: RE: Pg.pm

On Mon, 15 Sep 2003, Tom Bakken wrote:

: Phil,
: Making progress, but still not there yet.  I believe I'm now accessing
: postgres because I get complaints from postgres that root doesn't have
: access to certain tables, but now I'm getting a perl error:
: Perl: error in loading shared libraries:
: /usr/local/lib/perl5/5.8.0/auto/Pg/Pg.so: undefined symbol: Perl_safefree

This definitely means you need to recompile.

: I set up root as a user in postgres and am now attempting to recompile but
: when I run make, it returns:
: Pg.xs:16: libpq-fe.h: No such file or directory.

I'm not sure what kind of system you're installed on.  Make sure you have
the Postgres header files.  If you have a RedHat system, you need to install
the pgsql-devel RPM.  If you have a hand-install, the header files should be
installed already.

: I've set them and exported the two variables that the README talks about.

To cover all bases, they're set to the correct values, right? Specifically,
the INC-type variable should point to an include directory of some sort, and
the libpq-fe.h file should be in there.

: Maybe some of these clues will help those of you fluent in this sort of
: thing to pinpoint where the problem is.

I think you may want to resend this to the list.  I accidentally replied to
you off-list earlier.

More information about the Austin mailing list