[tpm] Bizarre bug or brain fade?

Uri Guttman uri at PerlOnCall.com
Tue May 12 11:11:35 PDT 2009

>>>>> "a" == arocker  <arocker at vex.net> writes:

  a> A program containing a fairly large "here document" is on a machine I
  a> cannot access directly. (Somebody else has to run it for me.) The code was
  a> substantially copied from a program that runs successfully there, but it
  a> crashes with a complaint that the terminal string was not found before EOF
  a> on input. (I can't quote Perl versions today.)

  a> I've tried the usual things to ensure that there are no invisible
  a> characters lurking on the line, &c., to no avail. The whole program cannot
  a> be run on my machine, but when I extracted the relevant portion for
  a> autopsy, it worked.

it could be line ending issues (cr/lf vs lf). this has been known to
break here docs when moved to/from winblows and unix flavors. so check
the line ending type on the platform and exactly what is in the file
there (use a text dump utility, not an editor).


Uri Guttman  ------  uri at stemsystems.com  --------  http://www.sysarch.com --
-----  Perl Code Review , Architecture, Development, Training, Support ------
--------- Free Perl Training --- http://perlhunter.com/college.html ---------
---------  Gourmet Hot Cocoa Mix  ----  http://bestfriendscocoa.com ---------

More information about the toronto-pm mailing list