[Pdx-pm] Kwiki 2 error, more info

Ingy dot Net ingy at ingy.net
Wed Mar 28 21:03:46 PDT 2007


I think I see what's going on here. I tried installing a new Kwiki instance
then switched to your plugin set and it worked perfectly.

Then I noticed you error message: Kwiki::process('Kwiki=HASH(0x8c3d35c)', 'config*.*', '-plugins', 'plugins') called at /var/www/pdxpmtest/kwiki/index.cgi line 4

I can tell the index.cgi is old, because those parameters (config*.*
etc) are no longer used. I forgot that `kwiki -update` doesn't
change index.cgi. I think that was so you can hack it and not lose
your changes.

Try removing index.cgi and rerun `kwiki -update`. If that works let me
know and I'll update the docs.

Sorry for the inconvenience. :\

Cheers, Ingy

On 28/03/07 11:28 -0700, Keith Lofstrom wrote:
> On Tue, Mar 27, 2007 at 03:36:57PM -0800, Bruce J Keeler wrote:
> > I figured I'd give this a quick try, but no luck so far.  I copied the 
> > existing pdx.pm.org site into a new virtual host and ran the upgrade 
> > procedure on it as mentioned in the UpgradingToKwiki2 link.  I took a 
> > brief look at it, but I'm at work, so I don't really have time to poke 
> > at this more.  Eric's welcome to prod at it too if he likes.
> > 
> >     http://pdxpmtest.drangle.com/kwiki/
> > 
> > Currently it barfs the following:
> > 
> > Can't call method "registry" on an undefined value at lib/Kwiki.pm line 9.
> >  at lib/Spoon/Base.pm line 89
> >     Spoon::Base::__ANON__('Can\'t call method "registry" on an undefined value at lib/Kw...') called at lib/Kwiki.pm line 9
> >     Kwiki::process('Kwiki=HASH(0x8c3d35c)', 'config*.*', '-plugins', 'plugins') called at /var/www/pdxpmtest/kwiki/index.cgi line 4
> On Tue, Mar 27, 2007 at 08:27:26PM -0700, Keith Lofstrom wrote:
> > I got exactly the same thing just a few minutes ago, and I was about to
> > paste the same error into an email to Ingy.  Since I already have the
> > kwikis set up,  it sure would be nice if I could just upgrade them.
> > The Typekey certification for spam blocking is a little surprising,
> > but if my users are OK with it then it is a good idea.
> A blank new kwiki2 works.  So it may be the conversion process, or it
> may be one of the plugins I'm using:
>       Kwiki::Display
>       Kwiki::Edit
>       Kwiki::Theme::Basic
>       Kwiki::Toolbar
>       Kwiki::Status
>       Kwiki::Widgets
>       Kwiki::RecentChanges
>       Kwiki::Archive::Rcs
>       Kwiki::Revisions
>       Kwiki::UserPreferences
>       Kwiki::UserName
>       Kwiki::Search
>       Kwiki::Edit::RequireUserName
>       Kwiki::Notify::Mail
>       Kwiki::Htaccess
>       Kwiki::Attachments
>         Kwiki::PrinterFriendly
> The last three are not in the list that a blank new kwiki makes. A
>   kwiki -remove Kwiki::Htaccess
> gives me the error:
>   Can't locate object method "plugins_file" via package "Kwiki::Config" at /usr/local/kwiki/lib/Kwiki/Command/V1.pm line 125
> I could debug all this stuff, but I think I will continue on with
> TWiki 4.1 and let somebody else debug kwiki 2.0.  Sigh.  It would have
> been nice if kwiki 2.0 "just worked";  perhaps in a few weeks it will.
> Keith
> -- 
> Keith Lofstrom          keithl at keithl.com         Voice (503)-520-1993
> KLIC --- Keith Lofstrom Integrated Circuits --- "Your Ideas in Silicon"
> Design Contracting in Bipolar and CMOS - Analog, Digital, and Scan ICs

More information about the Pdx-pm-list mailing list