[Pdx-pm] require 5.004

Austin Schutz tex at off.org
Wed Nov 13 14:37:13 CST 2002

On Wed, Nov 13, 2002 at 12:16:26PM -0800, Tom Phoenix wrote:
> On Wed, 13 Nov 2002, Thomas Keller wrote:
> > I am trying to install a module that has the line:
> > require 5.004;
> > The module has problems installing, this line is the only "conflict" or
> > dependency that seems awry. The module author wrote me  "Perl 5.6 has a
> > known bug that triggers this problem." I guess he's busy.
> Something doesn't make sense here. That require line tells Perl to check
> at runtime that you're running at least version 5.004. Perl 5.6 is at
> least 5.004, so that line shouldn't be the problem.

	Well if it was the problem that would certainly qualify as a bug :)

> There may be some bug in 5.6 which breaks the module, but that line
> shouldn't be the problem. And most bugs of 5.6 are fixed in 5.6.1, not to
> mention 5.8.

	What happens when you remove the require 5.004; line? It doesn't
actually _do_ anything, so removing it shouldn't break anything.


More information about the Pdx-pm-list mailing list