[Melbourne-pm] pod2html problem on Windows

benjamin.j.hayes at exxonmobil.com benjamin.j.hayes at exxonmobil.com
Sun Aug 1 21:43:24 PDT 2010

Hi Perl Mongers,

I'm in the process of porting a build script from Solaris to Windows. The
script packages up a collection of Perl scripts for distribution on our
corporate network and one of the things it does it to build all the POD
into a nice, pretty set of html pages. The code all lives in my TFS
workspace on my c: drive and I'm having trouble with pod2html accepting a
path which contains a : (like in c:\). I discovered this is because
pod2html (in Pod::Html) tries to split the podpath on the : character, so
it crashes because it attempts to open a file called C. Of course this all
worked perfectly on Solaris where file paths are sans : characters. I tried
replacing C:\ with \\$ENV{COMPUTERNAME}\c$, but it appears that only works
if you have admin rights on the machine, which in this instance I don't. It
seems inconceivable to me that pod2html doesn't work on Windows and I feel
there must be a simple solution, but I have not been able to find it. Can
anyone help?


Ben Hayes
Onsite Application Support Coordinator
ExxonMobil Technical Computing Company / Upstream IT
Upstream Technical Computing / UTC Applications / Application & Data
Esso Australia Pty Ltd
Room 5.36, 12 Riverside Quay, Southbank, VIC 3006, Australia
Phone: +61-3-9270-3538 Fax: +61-3-9270-3600  E-mail:
benjamin.j.hayes at exxonmobil.com

More information about the Melbourne-pm mailing list