perl scripts hang after migration to apache2.0.40

Stas Bekman stas at
Thu Jan 30 23:01:35 CST 2003

Kerry Seibold wrote:
> Hi All,
> I am setting up a new box to migrate my webserver to.
> Existing server is RH7.1 Apache 1.3.19: webserver works fine.
> New server (hostname webserver2): Have installed RH8 with Apache2.0.40.
> Have copied the complete /var/www from old to new.
> Have cut and paste and setup /etc/httpd/conf/httpd.conf and this tests ok.
> (httpd -t returns "Syntax OK").
> Testing the webserver on my lan, plain old html pages are served up ok, but
> some CGI's (Perl) serve back some data,
> then the browser just hangs waiting for more data.
> Apache error log file says:
> [Fri Jan 31 10:04:46 2003] [error] [client] (20507)The timeout
> specified has expired: ap_content_length_filter: apr_bucket_read() failed.
> I am using perl5, apache mod-perl,
> I have searched on google, and tried, and searched my
> perl-mongers archives, but can't find any clues.
> I selected a script to try to find out where the script appears to be
> hanging by inserting:
> print "ok to here #DEBUG<br>";
> print "</body></html>";
> exit;
> It seems to depend on how many variables have been declared??
> Does anybody have ideas about what the solution is?

First of all RH8 comes with pretty old mod_perl and Apache, so the first thing 
to do is to grab the latest Apache 2.0.44 and mod_perl 1.99_08 and try again.

If the problem is still there please post this question to the modperl list 
and we will take it from there.

Don't forget to complete the whole report as described here:

and include a short script that reproduces the problem and a relevant section 
of httpd.conf.

But only after you have tried with the recent versions of Apache/mod_perl.

Stas Bekman            JAm_pH ------> Just Another mod_perl Hacker     mod_perl Guide --->
mailto:stas at

More information about the Melbourne-pm mailing list