[Chicago-talk] Net::SFTP and SSH protocol

tiger peng tigerpeng2001 at yahoo.com
Mon Jul 25 07:47:37 PDT 2011

Test on another QA box(OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7c 30 Sep 2003) with debug turn on. The Perl script worked as expect without hanging. I do got same warning message when I run sftp manually on the QA box. 

No warning message for run Putty's psftp ( with verbose message segment copied below).

Server version: SSH-2.0-someServer someServer
We claim version: SSH-2.0-PuTTY_Release_0.60
Using SSH protocol version 2

I am waiting for permission to do the debug on the Production Box.

From: Shawn Carroll <shawn.c.carroll at gmail.com>
To: Chicago.pm chatter <chicago-talk at pm.org>
Sent: Monday, July 25, 2011 9:07 AM
Subject: Re: [Chicago-talk] Net::SFTP and SSH protocol

Have you turned up debugging to see where the connection is fouling up?

shawn.c.carroll at gmail.com
Perl Programmer
Soccer Referee

On Mon, Jul 25, 2011 at 09:04, tiger peng <tigerpeng2001 at yahoo.com> wrote:
> Hello all,
> When making SFTP connection from Linux (OpenSSH_3.6.1p2, SSH protocols
> 1.5/2.0) to EFT server on Windows 2008 (with SSH protocol 2.0), I got
> warning message "Authenticated with partial success. While I can manually
> get files from the EFT server, but my Perl script (use Net::SFTP) hangs.
> Do you know what cause the warning message? Is there any way to make the
> connection without the warning message or any way to have Net::SFTP ignore
> the warning message?
> Thanks,
> Tiger
> _______________________________________________
> Chicago-talk mailing list
> Chicago-talk at pm.org
> http://mail.pm.org/mailman/listinfo/chicago-talk
Chicago-talk mailing list
Chicago-talk at pm.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.pm.org/pipermail/chicago-talk/attachments/20110725/c9c573c7/attachment.html>

More information about the Chicago-talk mailing list