[ABE.pm] Is this safe coding practice?

John Cappiello john-abe at apt202.net
Fri Jun 1 09:50:16 PDT 2007

On Fri, Jun 01, 2007 at 12:25:22PM -0400, Faber J. Fedor wrote:
> and of course, this works fine:
>     ($MinY, $MaxY) = getMinMax(@foo);
> Is there anything wrong with calling it like this as well:
>     ($MinY, $MaxY) = getMinMax(@foo, @bar);
> or even as
>     ($MinY, $MaxY) = getMinMax(@foo, @bar, $fubar);

These all look fine to me within reason.  It all comes down to
readability.  Will you be able to look at this in three months and get
it?  I'm pretty sure they had things just like this in mind when they
designed it.  


More information about the ABE-pm mailing list