SPUG: perl version

Joshua ben Jore twists at gmail.com
Wed Jul 7 07:05:08 PDT 2010

On Tue, Jul 6, 2010 at 8:05 PM, jerry gay <jerry.gay at gmail.com> wrote:
> the smartmatch operator is broken (that is, it has incorrect behavior)
> in 5.10.0.  if you're upgrading, upgrade to at least 5.10.1.  however,
> why not consider 5.12.1?  at least take a look at the changelogs and
> compare.

For what it's worth, if you go up to 5.12 then you're also buying into
our newly found enthusiasm for ensure that patch releases in 5.12.x
are purely only bug or documentation fixes. You're newly only supposed
to get new features if you actually then upgrade to 5.${NEXT}. That
was never true for any earlier perl. So this is a case of perl
attempting to become even more careful about being backwards
compatible (while freeing up our 5.${NEXT} to move at a faster rate,


More information about the spug-list mailing list