SPUG: when is 5.10 not > 5.8?

Mike Schuh schuh at farmdale.com
Tue Jan 15 17:18:30 PST 2008

On Tue, 15 Jan 2008, jerry gay wrote:

>On Jan 15, 2008 12:58 PM, Mike Schuh <schuh at farmdale.com> wrote:
>> I'm trying to install some modules from CPAN, having just upgraded from
>> Perl 5.8.8 to 5.10.0  Most of what I want to install has worked OK.
>no, you upgraded from Perl 5.008_008 to 5.010_000.

Ah, OK.

>> In a few places, however, I get complaints about versions:
>>  - ERROR: perl (5.10.0) is installed, but we need version >= 5.8
>make sure your 'use 5.8' lines are modified to 'use 5.008', and all
>will work as expected.

Well, they aren't really my lines, but the module's I'm trying to load.

>it's rather unfortunate that perl's version is advertised as something
>it's not... or that it's stored as something it's not...

Agreed, and Andrew's follow up question is spot on.

>anyway, things will compare nicely if you fix as i've suggested.

Indeed they did - but the Magic Place is in _build/prereqs *after* "perl
Makefile.PL" is run.  There ain't no "use 5.8" line anywhere in the source.
After changing this as Jerry suggested, running "make && make test" is a
much happier experience.

But then the next module in my path to glory hits a different problem, but
now it's time to head to tonight's meeting.

Thanks, Jerry, for the tip.

Mike Schuh - Seattle, Washington USA

More information about the spug-list mailing list