SPUG: when is 5.10 not > 5.8?
jerry.gay at gmail.com
Tue Jan 15 13:08:32 PST 2008
On Jan 15, 2008 12:58 PM, Mike Schuh <schuh at farmdale.com> wrote:
> Hi all,
> I'm trying to install some modules from CPAN, having just upgraded from
> Perl 5.8.8 to 5.10.0 Most of what I want to install has worked OK.
no, you upgraded from Perl 5.008_008 to 5.010_000.
> In a few places, however, I get complaints about versions:
> - ERROR: perl (5.10.0) is installed, but we need version >= 5.8
> requires perl '5.8'; you have only 5.010000; giving up
> Any suggestions?
make sure your 'use 5.8' lines are modified to 'use 5.008', and all
will work as expected.
> perl -v returns
> This is perl, v5.10.0 built for i686-linux
it's rather unfortunate that perl's version is advertised as something
it's not... or that it's stored as something it's not... anyway,
things will compare nicely if you fix as i've suggested.
More information about the spug-list