SPUG: shebang line on Suse (oxymoronically) requires an option

Andrew Sweger andrew at sweger.net
Wed Aug 2 08:45:36 PDT 2006

On Tue, 1 Aug 2006, Michael R. Wolf wrote:

> Recently, I tried moving the -w from the shebang line to a 'use warnings'
> statement, and found that something in the Suse shebang processing won't
> allow me to have a processor without a flag.  What gives?  Anyone else seen
> this?  I get a message from the shell indicating an illegal processor, but
> it doesn't mention /usr/bin/perl in the error message.
> It doesn't matter what the option is, but I must have an option.  My first
> guess was that if the shebang line contained qq{#!/usr/bin/perl\r} (having
> come from a DOS-ish system (my XP laptop) that the processing might be
> confused.  I ran the script through dos2unix to make sure that it had
> qq{#!/usr/bin/perl\n}, but that didn't make a difference.
> Other ideas?

Check for /perl\s+$/. That might be choking it.

Andrew B. Sweger -- The great thing about multitasking is that several
                                things can go wrong at once.

More information about the spug-list mailing list