SPUG: loading a module

Medrano-Zaldivar, L E LMedrano-Zaldivar at ciber.com
Wed Aug 10 18:59:23 PDT 2005

I installed the module using perl -M'CPAN' -e shell option. I didn't "make install". what other options do I have?


From: Ryan Allen [mailto:ryan at the-summit.net]
Sent: Wed 8/10/2005 7:46 PM
To: Medrano-Zaldivar, L E
Subject: Re: SPUG: loading a module

your module never made it to one of those directories listed there.
Did you run "make install"?


* Medrano-Zaldivar, L E <LMedrano-Zaldivar at ciber.com> wrote on [08-10-05y 18:30]:
> Gang,
> I have this problem I install the module Net::Blogger but perl has some problem loading this particular module. I have this script:
> #!/usr/bin/perl
> use Net::Blogger;
> when I ran it I have this error:
> Can't locate Net/Blogger.pm in @INC (@INC contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-th
>  read-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at x.pl line 2.
> BEGIN failed--compilation aborted at x.pl line 2.
> Anybody can help me to debug what can we wrong with this or how can make perl to load  this module?
> Thanks,
> Luis
> _____________________________________________________________
> Seattle Perl Users Group Mailing List 
>      POST TO: spug-list at pm.org
> SUBSCRIPTION: http://mail.pm.org/mailman/listinfo/spug-list
>     MEETINGS: 3rd Tuesdays, Location: Amazon.com Pac-Med
>     WEB PAGE: http://seattleperl.org/


|     ryan at the-summit.net     |
|  http://www.the-summit.net  |

More information about the spug-list mailing list