SPUG: Help with DBI/ppm/ppd/mysql?

John hotscripts at thingk.net
Wed Nov 17 12:52:04 CST 2004

>Unsupported driver MT::ObjectDriver::DBI::mysql: DBI object version 1.45 
>does not match $DBI::VERSION 1.40 at C:/Perl/lib/DynaLoader.pm line 253

I migrated to a new W2k advanced server machine and have never been able to 
restore my Movable Type v2.51 installation.  I loaded Activestate's 5.8.4, 
the new DBI doesn't match the old MT perl code which requires 5.0005 (or 
later?) and dbi 1.40.  That is...after using ppm install dbi I see an error 
about how the code is calling for dbi-1.40 and doesn't match the 
dbi-1.45  just installed.  This is a windows 2000 advanced server and I 
always get DBI-1.45 no matter what repository I point to.  I'm over my 
head, but I think I may need to back peddle to an older version of perl and 
dbi to get this old MT system to work.

I'm looking to hire a consultant for the solution if I don't get a 
"stupid-simple" (me) answer via email soon.   Any takers?

Yours truly,

John Marston
(253) 472-2986 

More information about the spug-list mailing list