SPUG: Overly clever?
adamm at wazamatta.com
Sat May 22 01:48:25 CDT 2004
On 21-May-2004 13:13 -0700, Michael R. Wolf wrote:
> First, a maintenance point -- since "Whizbang" seems a strange name
> (i.e. likely to be changed by someone when you publish it), perhaps a
> $package_name scalar could hold that, *and* be used in all the warn
> messages. Change it once, and have all references change. Constant
> refactoring, as Ingy would say.
Better yet, use the __PACKAGE__ literal in the warnings, etc., then
just change the package name where it's declared if/when you desire.
Adam Monsen <adamm at wazamatta.com>
More information about the spug-list