[Omaha.pm] unless ($current_count % 100) {

Theodore Katseres tedkat at gmail.com
Fri May 27 09:04:09 PDT 2005


On 5/27/05, Jay Hannah <jay at jays.net> wrote:
> 
> Laugh... This
> 
>     $current_count++;
>     unless ($current_count % 100) {
>        $self->logger->info("   $current_count rows done...");
>     }
> 
> is just an evil way of writing
> 
>     $current_count++;
>     if ($current_count % 100 == 0) {
>        $self->logger->info("   $current_count rows done...");
>     }
> 
> I think the latter is much more readable. Yes/no?

  About the same I'd say :) 
    But then again I'm Evil.

-- 
Ted Katseres


More information about the Omaha-pm mailing list