[Omaha.pm] unless ($current_count % 100) {

Jay Hannah jay at jays.net
Fri May 27 08:56:44 PDT 2005


Laugh... This

    $current_count++;
    unless ($current_count % 100) {
       $self->logger->info("   $current_count rows done...");
    }

is just an evil way of writing

    $current_count++;
    if ($current_count % 100 == 0) {
       $self->logger->info("   $current_count rows done...");
    }

I think the latter is much more readable. Yes/no?

j




More information about the Omaha-pm mailing list