[Chicago-talk] setting up cpan

Leland Johnson easyasy2k at gmail.com
Tue Dec 7 12:36:28 CST 2004

Looks like it might want Term::ReadKey or some other terminal reading module.

You might want to try just installing CPANPLUS though - it will
supersede CPAN.pm in 5.10.

On Tue, 07 Dec 2004 00:38:17 -0600, Jay Strauss <me at heyjay.com> wrote:
> Hi, can't find my answer on google.  I've built a new box, and when I,
> cpan I get:
> iron:~# cpan
> cpan shell -- CPAN exploration and modules installation (v1.7601)
> ReadLine support enabled
> Can't ioctl TIOCGETP: Invalid argument
> Consider installing Term::ReadKey from CPAN site nearby
>          at http://www.perl.com/CPAN
> Or use
>          perl -MCPAN -e shell
> to reach CPAN. Falling back to 'stty'.
>          If you do not want to see this warning, set PERL_READLINE_NOWARN
> in your environment.
> cpan still works and I can get install packages, but the warning is
> annoying.
> I'm running Debian/Sarge, I can figure out what I haven't installed that
> is giving me this error
> Thanks
> Jay
> _______________________________________________
> Chicago-talk mailing list
> Chicago-talk at mail.pm.org
> http://mail.pm.org/mailman/listinfo/chicago-talk

Leland Johnson

More information about the Chicago-talk mailing list